Odyssey Electronic Delivery

HOWTO: Setting Up Electronic Delivery
HOWTO: Setting Up Electronic Delivery on Multiple Machines
HOWTO: Setting up Remote Storage for Electronic Delivery Documents
HOWTO: Updating to ILLiad Version 6.2 - Installing Odyssey
INFO: Ariel 4.1 and ILLiad
PROBLEM: ILLiad gives Input Filename not Valid error when importing color TIF files from Ariel
PROBLEM: Electronic Delivery Processing Option Grayed Out in the ILLiad Client
Setting Up Odyssey Electronic Delivery
HOWTO: Setting Up Electronic Delivery
January 5, 2006

SUMMARY

In order to set up electronic delivery on a client machine, a few keys must be set. Below are the keys found in the Customization Manager under Borrowing .. Electronic Delivery.

EXAMPLES

ArielPath: This is the location of the Ariel received files that ILLiad imports for delivery. The default location for version 3 of Ariel is: c:\Program Files\RLG\Ariel\In\ - be sure that there is a backslash at the end of the directory path.

CheckForPDFFileExists: This key is an internal setting used when sending the request to the server. It should be set to Yes.

DaysBeforeElectronicDeliveryCleanup: The number of days a request remains on the server before being removed by the ILLiadCleanup program.

EDTempPath: This key should be set to c:\illiad\elecdel\ - remember the backslash at the end. In order to activate electronic delivery on the client machine, the elecdel folder needs to be created in the c:\illiad folder.

ElecDelAllowRapidMatch: This key allows the client to match ILLNumbers with negative numbers. This is only necessary if your site receives requests that are processed by Rapid.

ElecDelCustomerDeleteDelay: The number of days after a customer "deletes" a request on the web, before the ILLiadCleanup removes the file from the server.

ElecDelDefaultZoom: The percentage of zoom for the incoming articles viewed in the electronic delivery screen. Normally a value of 40% or so is ideal.

ElecDelPath: The locaion on the server where the pdf files should be copied to. This key should be from the perspective of the client machine, however, so a share should be created for the pdf directory on the server. The staff using the client machine will need to have write access to that share on the server. An example value would be: \\illiadserver\elecdelshare\

ElecDelPrintAllCheckboxDefault: This key allows staff to have all requests in the Print box print and check in at once.

ElecDelShowPDFAfterConversion: This key originally was designed for testing electronic delivery and would have the PDF file open after each conversion. Once in production, this key should most likely be set to No.

ElectronicDeliveryEMailFileName: The name of the email template - normally elecdel.txt - that is used for sending notifications to customers. The template is located in the path set by EMailLocation.

ElectronicDeliveryEMailSubject: The subject of the email notification sent to customers when the request is moved to the server.

PDFPath: The location ILLiad creates the pdf files in after converting the tiff files. By default, this should be set to c:\illiad\elecdel\ (don't forget the backslash at the end).

RemotePDFStorage: A Yes/No value that determines if the pdf files are stored in a separate directory from the default c:\inetpub\wwwroot\illiad\pdf\ folder on the server. If the pdf files are stored in a separate folder, then that folder must be shared as a Web Share of pdf (right click on the folder on the server and go to Properties to set up the web share).

UseOldElecDelForm: This key should be set to No. The new electronic delivery form has PDF conversion built into the client. In order to use the new electronic delivery form, be sure that these three files are in the ILLiad share (or the same folder where ILLiadClient is running) - CRDE2001.dll, ISP2000.dll, and wPDF010A.dll.

WebPDFPath: The location of the pdf files on the server. Normally it is the pdf folder in the illiad web folder - i.e. c:\inetpub\wwroot\illiad\pdf\ but if RemotePDFStorage is set to yes, it can be any folder on the server. This should be the same location as ElecDelPath, except from the perspective of the server (a local path).

HOWTO: Setting Up Electronic Delivery on Multiple Machines
January 5, 2006

SUMMARY

Electronic Delivery was originally designed for processing on the same machine as the Ariel workstation. The ArielPath would be a local directory on the electronic delivery machine where the incoming Ariel files are stored. The staff could then process those Ariel files in the ILLiad Client on the same machine and send them to the server for customers to download as pdf files.

There are, however, other scenarios that can also work for electronic delivery processing. Electronic delivery can be processed on multiple machines in the same office and even connect to different Ariel machines for incoming requests. Below are several examples for setting up electronic delivery on separate client workstations.

EXAMPLES

To allow one or multiple ILLiad client workstations to import requests from a single separate Ariel workstation, do the following steps:

  1. Share the Ariel received folder on the Ariel workstation as a Windows share. ILL staff will need read and write access to this share to copy and delete the files. The Ariel received directory is typically c:\Program Files\RLG\Ariel\In\ for version 3 and higher of Ariel. Share the folder as "ArielIn", for example.
  2. Change the ArielPath key in the Customization Manager to be the share created on the Ariel workstation. For example, the path would be set to "\\ArielMachine\ArielIn\" (don't forget the \ at the end of the path).
  3. Each electronic delivery processing machine would need to have a c:\illiad\elecdel folder created in order to access the electronic delivery form in ILLiad. Any of those clients could then push the Process Electronic Delivery Files to import the Ariel files to that local client machine. The files would at that point remain on the individual client machine until moved to the server or printed. Timing would be key to insure that no two electronic delivery client machines are trying to import Ariel files at the same time.

To allow multiple ILLiad client workstations to import requests from multiple Ariel workstations, do the following steps:

  1. On each Ariel workstation, share the Ariel received folder as a Windows share. ILL staff will need read and write access to this share to copy and delete the files. The Ariel received directory is typically c:\Program Files\RLG\Ariel\In\ for version 3 and higher of Ariel. Share the folder as "ArielIn", for example. The share can be the same name on each workstation or separate names.
  2. On each electronic delivery processing workstation, map a drive to its respective Ariel workstation. Each electronic delivery workstation can only import from on Ariel workstation. But in this scenario, electronic delivery machine A can import from Ariel machine A while electronic delivery machine B can import from Ariel machine B. Make sure that the mapped drive letter is the same on each machine even though they are connecting to different shares. For example, electronic delivery A would map a drive X to \\ArielMachA\ArielIn\ while electronic delivery B would map a drive X to \\ArielMachB\ArielIn\.
  3. Change the ArielPath key in the Customization Manager to be the mapped drive. In the previous example, the path would be set to "X:\" (don't forget the \ at the end of the path).
  4. Each electronic delivery processing machine would need to have a c:\illiad\elecdel folder created in order to access the electronic delivery form in ILLiad. Any of those clients could then push the Process Electronic Delivery Files to import the Ariel files to that local client machine from their own Ariel workstation. The files would at that point remain on the individual client machine until moved to the server or printed. No imports would overlap as each client would only be interacting with one other workstation and the server. Requests at the status In Electronic Delivery Processing could be physically at any of the electronic delivery processing workstations.

MORE INFORMATION

Setting Up Electronic Delivery

HOWTO: Setting up Remote Storage for Electronic Delivery Documents
January 5, 2006

SUMMARY

By default, the Electronic Delivery documents are stored in the c:\inetpub\wwwroot\illiad\pdf folder (or if you change the web root, the pdf folder is located inside the folder designated by the WebPath customization key). If you want to store these files in a different location, you have to make several changes.

 

SETUP

To use this option:

Since the PDF documents are stored in a folder outside of the path of the Default Web Site (\inetpub\wwwroot\) a virtual directory will need to be created to point the ILLiad web pages to the location where the PDF documents are stored when the patron is accessing them. Here are steps to create the virtual directory:

HOWTO: Updating to ILLiad Version 6.2 - Installing Odyssey
January 6, 2006

SUMMARY

This update assumes that you are at the latest versions of all components before updating to version 6.

The latest version for each component before this release is:

Client - Version 6.1.5.0
Web DLL - Version 6.1.2.0
Web Reports - Version 6.1.0.0
Customization Manager - Version 6.0.0.0
User Manager - Version 5.0.0.0
Server Automatic Updater - 6.0.0.0
Electronic Delivery Cleanup - Version 4.0.0.0
Connector - Version 6.0.2.0

Macros are not updated in this release so their version number is ignored.

When you first open the AutoUpdater, you will get a message about three keys missing: VersionGateway, VersionISO and VersionOpenURL. Click OK past these as the new AutoUpdater will create these keys. The first step is to update to the latest AutoUpdater. It should be the first update in the list and is version 6.2.0.1. Only run this one update as you will need the latest Updater to retrieve the rest of the updates.

Be sure to get the latest updater from the x:\illiad\setup\AutoUpdaterUpdates\6.2.0.1\ folder and replace it where you run the ILLiad Updater (usually c:\illiad\admin). Manually replace that file and there is no reason to reboot.

Run the new Auto Updater. You may be prompted to enter your ILLiad ISO Directory if it does not exist. Enter the directory where you have installed ISO services (generally c:\illiad\ISO\). Leave this value as the default if you are not running ISO services. The same is true for your OpenURL directory and your Connector directory. Go ahead and make a directory to match the value if you do not have these installed. This will prevent further errors from appearing everytime you run the updater.

NOTE: If you were not prompted for your ISO directory, Connector directory or OpenURL directory and you still see errors about keys not found for VersionGateway, VersionISO and VersionOpenURL, STOP NOW AND VERIFY YOUR UPDATER VERSION. You are most likely still running the old ILLiadUpdate.exe and your updates will not work with this version.

Verify all of the directories listed on the left. Be sure to verify the new Connector directory, OpenURL directory and ISO directory.

If you are not currently using OpenURL or ISO, you can ignore those folders but you will also want to skip over those updates in the list of available ILLiad updates. Otherwise, the Updater will attempt to download and replace files that don't exist and you will get errors.

Check the boxes for all available updates that apply to you. If you would like to use Odyssey, but have not installed ISO on your ILLiad server, you will need to follow the instructions within the Odyssey Overview Manual for setting up the Gateway first before downloading the latest Gateway. You can run the Gateway update after installing Java runtime and the Gateway service. This will automatically replace the ILLiadGateway and CRDE2001.dll files. If you check the box to download the Gateway before installing Java and the Gateway service, you will need to manually update the ILLiadGateway.exe and CRDE2001.dll files. Details on this procedure are in the Odyssey Overview Manual (Chapter 5) on setting up Odyssey.

If the Updater can not replace a file that was downloaded, an error message will appear explaining to which folder the file was downloaded and where it was trying to replace the existing file. The download will continue but you will need to manually replace that file and verify the directory for future updates.

After the files have been downloaded and the database changes made, you will be prompted to reboot the server. This will complete the replacement of all the updated files. Those files for which you received errors will not be replaced automatically during the reboot.

After rebooting, check each of the files updated to be sure they are the correct version. You should also have a file in the same directory that is ILLiadFileName.exe.20030424163000.replaced where the string of numbers is the date and time the file was replaced. This was the file that was renamed and then replaced with the current file.

Continue with the update for Odyssey by installing the Odyssey Gateway. Instructions for this are in chapter 5 of the Odyssey Overview Manual.

MORE INFORMATION

Changes in ILLiad Client 6.2.0.1
http://portal.knowledgebase.net/article.asp?article=58611&p=1901

Changes in ILLiad Customization Manager 6.2.0.1
http://portal.knowledgebase.net/article.asp?article=58614&p=1901

Changes in ILLiad Auto Updater 6.2.0.1
http://portal.knowledgebase.net/article.asp?article=58618&p=1901

Changes in ILLiad Gateway 6.2.0.1
http://portal.knowledgebase.net/article.asp?article=58620&p=1901

Changes in ILLiad Web DLL 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58613&p=1901

Changes in ILLiad User Manager 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58615&p=1901

Changes in ILLiad Electronic Delivery Cleanup 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58616&p=1901

Changes in ILLiad Connector 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58617&p=1901

Changes in ILLiad OpenURL 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58619&p=1901

Changes in ILLiad ISO ILL 6.2.0.0
http://portal.knowledgebase.net/article.asp?article=58621&p=1901

What Ports are Required to be Open for General ILLiad Use
http://portal.knowledgebase.net/article.asp?article=46967&p=1901

INFO: Ariel 4.1 and ILLiad
March 7, 2006

SUMMARY

Ariel functionality changed with Ariel version 4.1 in such a way that earlier versions of the ILLiad client were no longer able to delete the image files from Ariel once they were imported into ILLiad for processing.

ILLiad is able to delete image files from the Ariel 4.1 if the default options for installing Ariel 4.1 are followed and if the ArielType and ArielDatabaseAddress keys in the OCLC ILLiad Customization Manager have the correct values. These keys were part of the version 7.0.4.0 ILLiad Client release.

If changes are made from the default values when installing Ariel 4.1, ILLiad may not be able to delete the Ariel image files. Specifically, if the sa password for the Ariel database is changed from the default password that is part of the Ariel 4.1 installation, ILLiad will not be able to connect to the database to remove the image files.

Both new keys are viewable in the Customization Manager under Borrowing - Electronic Delivery.

ArielType specifies the method ILLiad should use to delete the Ariel image files. Possible values for this key are File (for pre-4.1 versions of Ariel) andQuery (for version 4.1 and higher of Ariel). If this key is set to File, the system attempts to delete the image files using the old method. If this key is set to Query, the system attempts to delete the image files from the Ariel 4.1 database via query.

ArielDatabaseAddress specifies the IP address of the Ariel Database. This key is only used if the ArielType value is set to Query. The ArielDatabaseAddress value defaults to the localhost address (127.0.0.1). If the Ariel Database is located elsewhere, this key will need to be set to the IP address of that location.

AFTER UPDATING

After updating to ILLiad Client version 7.0.4.0, no changes to these keys are necessary unless you have implemented Ariel version 4.1. Ariel importing will continue to work as it did before the update.

Once you implement Ariel 4.1, you will need to change the ArielType value to Query and make sure that the ArielDatabaseAddress is set to the correct IP address for your Ariel Database. For most installations, the localhost address will be correct. If necessary, change this IP address to point to the correct address.

Note: If the designated IP address for the ArielDatabaseAddress key is not the local Ariel machine, port 1433 will need to be open between the local Ariel machine and the Ariel Database Server.

PROBLEM: ILLiad gives Input Filename not Valid error when importing color TIF files from Ariel
January 6, 2006

SYMPTOMS

When importing a color TIF file from Ariel into ILLiad Electronic Delivery, ILLiad responds with an error and does not convert the file correctly.

 

ERROR MESSAGES

Input Filename not Valid is the error message that is received when importing.

 

CAUSE

ILLiad Electronic Delivery does not currently support Color TIF files delivered by Ariel.

 

RESOLUTION

This will be updated in a future release of ILLiad.

PROBLEM: Electronic Delivery Processing Option Grayed Out in the ILLiad Client
January 6, 2006

SYMPTOMS

The Electronic Delivery Processing option in the Receives menu of the ILLiad Client is grayed out.

CAUSE

The C:\illiad\elecdel\ folder does not exist on the client machine.

RESOLUTION

Create a folder called "elecdel" in C:\illiad on the client machine. Note that you only want to make this folder on machines that will be processing incoming electronic delivery items to avoid files being downloaded to the wrong machine.

MORE INFORMATION

See the Instructions for setting up Electronic Delivery: Electronic Delivery Setup.

This was changed as of ILLiad 7.1. Starting in that version, the client will prompt you to create the directory if necessary.

 

Setting Up Odyssey Electronic Delivery
January 25, 2006

This is a test article