SYMPTOMS
Email Copies are not available for all email functions.
CAUSE
Email Copies are not available for newer email functions.
RESOLUTION
Email Copies are no longer supported. All emails are held inside ILLiad, so outside copies are no longer necessary.
SUMMARY
In Borrowing and Doc Del you may choose not to send an email notification. This may be accomplished by changing the EMailFileName key value(s) to be "None" instead of the text file denoting the name of the EMail template (example illartdel.txt).
The most common example of this woud be in the case of Articles to be delivered via mail. Many sites will choose to skip notification for this.
EXAMPLES
Relevant Keys - Borrowing:
ILLArticleDeliveryNotifyEMailFileName
ILLArticleNotifyEMailFileName
ILLLoanDeliveryNotifyEMailFileName
ILLLoanNotifyEMailFileName
Relevant Keys - Doc Del:
ILLDDArticleDeliveryNotifyEMailFileName
ILLDDArticleNotifyEMailFileName
ILLDDLoanNotifyEMailFileName
ILLDDLoanDeliveryNotifyEMailFileName
To bypass sending EMails in Borrowing for Articles Delivered, perform the following actions:
Note: For Shared Server situations, the ILLArticleDeliveryNotifyEMailFileName may be named differently. It will appear as XYZArticleDeliveryNotifyEMailFileName, where XYZ is the symbol for your site on the Shared Server system.
SUMMARY
There is a checkbox on the borrowing cancellation form that will allow you to send the cancellations to a print queue instead of (or in addition to) sending the normal email. If this checkbox is selected, all notifications will also be written to the BCancel.dbf file, which would be referenced by the BorrowingCancellation.doc Word template.
Note: The BorrowingCancellation.doc Word template is not a part of the standard print documents package provided with your ILLiad installation. Print notification for cancellations is so rarely used that those installations that wish to do so should create their own document template for this.
PROCESS
SUMMARY
For an undetermined amount of time, the default documents for the three Lending Overdue Letters were available for download from our server without an assigned data file from which to get the mail merge information needed for them to work properly. If you have these documents, and they do not function because of this, you have two options to fix them.
Option 1: Add the data source to the document through the mail merge helper in Word. The data files should be matched to the documents as follows:
Option 2: Download new versions of the documents, complete with designated data sources, from here. Then replace your existing LendingOverdueLetter documents with the new ones.
SUMMARY
If anything should happen to your ILLiad Email Templates, you can download a zip file of the latest Email Templates supplied. These documents would replace those in the email folder either on your local machine or on the file server in the ILLiad share.
SUMMARY
To setup overdues in ILLiad, there are several keys that apply. All of the overdue days only apply to which template is used when sending overdues. Overdues are only sent when a staff member goes to the client and clicks the button to send the emails (for Borrowing) or print the files (for Lending). The following keys need to be set for Borrowing:
OverdueGraceDays: This key should be set to the number of days after the due date before overdues should start being sent. For example, to have the first overdue notice apply after the book is 2 days overdue, the OverdueGraceDays should be set to 2. NOTE: OverdueGraceDays cannot be set to a negative number in order to create a reminder notice. The is being considered as a possible future enhancement.
OverdueNoticeOneDays: This key is the number of days after the due date when the second overdue should be active. For example, if the second overdue should be sent after 9 days, then the OverdueNoticeOneDays would be set to 9.
OverdueNoticeTwoDays: This key is the number of days after the due date when the third overdue should be active. For example, if the third overdue should be sent after 16 days, then the OverdueNoticeOneDays would be set to 16.
BlockOnThirdOverdue: This is a Yes/No key to give the option of not blocking borrowing customers when their items are in the third category of overdues. By default, this key is set to Yes.
For the previous examples, overdues would be in three categories. Items that were 2-9 days overdue would be in the first overdue category. Items that were 9-16 days overdue would be in the second overdue category. And items that were over16 days overdue would be in the third overdue category. Overdues would still only be sent whenever the overdue button is clicked.
SYMPTOMS
When viewing items on the Awaiting Customer Contact form, double-clicking to mark a notification as sent or clicking the Start Automatic E-Mail leaves items in the queue to be notified still. Those requests remain "stuck" in Awaiting Customer Contact and cannot be notified by phone or email.
CAUSE
The DeliveryMethod or LoanDeliveryMethod for the customers is not set to a value of "Hold for Pickup" or "Mail to Address". Note that those values are case-sensitive, so the values must match exactly. If the values are anything other than those, ILLiad does not understand what type of email to send to the customer (delivery versus pickup notice).
RESOLUTION
Edit the web pages to only allow values of Hold for Pickup or Mail to Address. Also update the customer's information so that their delivery methods are correct.
MORE INFORMATION
See INFO: Valid Delivery Methods for Loans and Articles in ILLiad
SYMPTOMS
When attempting to send an email for a customer, you receive an email error and the email is not sent.
ERROR MESSAGES
Email not sent! Error: 503 Need RCPT (Recipient) (0)
CAUSE
This is generally caused by either the email address being incorrect for the user, or the NVTGC field being blank for the user.
While we have not experienced this ourselves, we have had several reports from various ILLiad users that there may also be an issue with McAfee VirusScan 8 software in conjuction with ILLiad. When version 8 is installed, it prevents access to port 25 which is needed for email notification from ILLiad. For campuses using ePO an administrator will need to change a setting under 'access protection policies' for VirusScan 8. The rule 'Prevent mass mailing worms from sending mail' blocks port 25 which is what is causing the problem. Unchecking this rule seems to solve the problem. For campuses not using ePO, an administrator will have to make that exception on all library staff machines.'
RESOLUTION
If the email address is incorrect, change the email address to be valid and resend the email.
To check the NVTGC field, look up the customer from the Edit Customer screen and check the NVTGC field at the bottom. If it is blank, it should be changed to match a valid site. If you are a single ILLiad site, this is usually ILL. If you are a shared ILLiad site, then you should change it to a valid SSS NVTGC code.
SYMPTOMS
On the main menu of ILLiad, there are items listed as Awaiting Customer Contact, but when you look at the Customer Contact screen, nothing shows up.
CAUSE
This is caused by a blank NVTGC field on the user's record.
RESOLUTION
Edit the user using the Edit Customer form and replace the NVTGC field with a valid code. For single ILLiad sites, this is ILL. For shared ILLiad servers, use a valid code.