Billing

HOWTO: Charging Reciprocal Fees to the Borrowing Customer
HOWTO: Setting Up EFTS
HOWTO: Setting up ILLiad to bill for a lost or damaged item
HOWTO: Using a SQL Query to setup billing categories
INFO: Billing Manager Report Files
INFO: Printing Invoices by Month
PROBLEM: Billing Amount Not Found for Document Type X
HOWTO: Charging Reciprocal Fees to the Borrowing Customer
HOWTO: Charging Reciprocal Fees to the Borrowing Customer
January 6, 2006

SUMMARY

Institutions sometimes wish to charge their Borrowing customers only whatever fees that the Borrowing library was charged by the Lending Library. In such cases, the normal practice of setting specific charges in the billing tables does not typically work, as the charges in question will very from transaction to transaction depending on the Lending institution's billing policies.

To allow the possibility of Reciprocal Charging, set up the following Billing Addition:

In the course of processing an incoming Borrowing Item for the customer, you will check the item in from the lending institution as normal.

HOWTO: Setting Up EFTS
January 5, 2006

SUMMARY

ILLiad allows libraries who participate in Docline's EFTS to bill within the client automatically and generate EFTS files for each month.

First, EFTSActive must be set to Yes. This key is in the Customization Manager under Lending .. Billing. Also, the EFTS participants must be marked as such in the Address Maintenance form. To set the library as an EFTS participant, search for that library and check the checkbox for EFTS. Save changes for the Address.

When billing for EFTS items, the billing form appears the same as for other billing. The total at the bottom will say EFTS Total instead of Total or IFM Total.

To generate EFTS files for each month, open the Invoice form from the main menu by choosing Billing .. Search/Generate Invoices. Choose a date range of the previous month ( i.e. 7/1/2002 - 8/1/2002) and click the button to generate the EFTS file. Give a file name when prompted. Once the file is generated you can find it in the location you specified.

HOWTO: Setting up ILLiad to bill for a lost or damaged item
January 5, 2006

SUMMARY

When an item becomes lost or damaged by one of your customers, you can set ILLiad up to send them an email with charge information in it. You can add this new email template through the Customization Manager and through additional email text files.

 

EXAMPLE

Open the Customization Manager and look under System|EMail for the EMailRouting table. Add a new entry for the Lost/Damaged item for the Borrowing process by adding the following fields:

Field Name Value
ProcessType Borrowing
Name Lost or Damaged Item
DefaultToAddress  
DefaultToName  
DefaultCCAddress  
DefaultSubject Lost or Damaged Item
DefaultFromAddress ill@yourlibrary.edu
DefaultFromName ILLiad
DefaultStatus  
FileNameLoan lostloan.txt
FileNameArticle lostart.txt
NVTGC If you have a SSS setup, this will be your site symbol in ILLiad. If not, this will be ILL.

Once you have added the record to the EMailRouting table, you need to create the loan and article templates. Take a template you are already using for emails and edit it to include the information about the item being lost or damaged. A good one to start from would be ILLLoan.txt and ILLArt.txt. These will be on your server in the default email directory, or another location depending on your setup. Your system administrator should know where these files are located. Once they have been edited, put them in the default email directory.

Once you close and reopen the client, a new entry (Lost or Damaged Item) will appear on the EMail menu from the request forms.

 

MORE INFORMATION

More information about EMailRouting setup can be found in the Implementation Guide.

HOWTO: Using a SQL Query to setup billing categories
January 6, 2006

SUMMARY

If you have a large list of items to update when setting up ILLiad, or a large list of items to change because a billing category has changed, you can use a SQL Query and the Microsoft SQL Server Query Analyzer to make the change in the ILLiad database. Remember that any billing categories that you add this way must exist in the BillingDefaults table as well.

 

EXAMPLES

If you wanted to set all libraries in the database to be exempt:

use ILLData
go
update LenderAddresses set BillingCategory = 'Exempt'

Be careful with this type of query - this will change ALL BillingCategories, regardless of what they are set to now.

 

If you wanted to set all Virginia libraries in the database to be "VirginiaBilling":

use ILLData
go
update LenderAddresses set BillingCategory = 'VirginiaBilling'
where ((Address1 like '%VA%') or (Address2 like '%VA%') or (Address3 like '%VA%'))

This query uses the "like" operator and the wildcard operator "%". This will select any address that has the letters VA anywhere in Address1, Address2 or Address3 and change the BillingCategory to 'VirginiaBilling'.

 

If you wanted to set libraries with these symbols (ABC, BCD, CDE, DEF, EFG) in the database to be "SpecialLibraries"

use ILLData
go
update LenderAddresses set BillingCategory = 'SpecialLibraries'
where LenderString = 'ABC' or
LenderString = 'BCD' or
LenderString = 'CDE' or
LenderString = 'DEF' or
LenderString = 'EFG'

Using this method, you could take a long list of symbols, and insert the "Lenderstring = '" part and the "' or " part programmatically in order to change a large number of symbols at the same time, without having to edit each one by hand in the client.

MORE INFORMATION

More information on how the SQL Query language works in Microsoft SQL Server can be found in the Online Books under the Transact-SQL reference.

INFO: Billing Manager Report Files
April 14, 2006

SUMMARY

In a standard installation of the Billing Manager, the reports are stored within the ILLiad share in the \billing\reports subfolder. If for some reason you need to replace the reports with the standard files from installation, you can download them from here.

RAV REPORT FILE DOWNLOADS

Reports folder zip file (latest versions of all report files)

Customer Balance Summary report zip file (omitted from initial upgrade files)

INFO: Printing Invoices by Month
January 6, 2006

SUMMARY

When billing by date ranges in ILLiad, there are a few steps necessary to print invoices for any date range. For example, to generate and print invoices for the month of July in lending, do the following steps:

PROBLEM: Billing Amount Not Found for Document Type X
January 4, 2006

SYMPTOMS

When billing in Borrowing, an error is displayed of: Billing Amount Not Found for Document Type X, where X is a valid ILLiad document type.

 

ERROR MESSAGES

Billing Amount Not Found for Document Type... X.

 

CAUSE

This is generally caused by either a missing billing account for the user, or a missing document type in the BillingDefaults table.

 

RESOLUTION

First, check the user to make sure that they have a valid account type assigned, and that that account exists in the BillingDefaults table.

If that is the case, then also check to make sure that the BillingDefaults table has an entry for document type X.

HOWTO: Charging Reciprocal Fees to the Borrowing Customer
January 5, 2006

SUMMARY

Institutions sometimes wish to charge their Borrowing customers only whatever fees that the Borrowing library was charged by the Lending Library. In such cases, the normal practice of setting specific charges in the billing tables does not typically work, as the charges in question will very from transaction to transaction depending on the Lending institution's billing policies.

To allow the possibility of Reciprocal Charging, set up the following Billing Addition:

In the course of processing an incoming Borrowing Item for the customer, you will check the item in from the lending institution as normal.