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| Revised | : | January 6, 2006 (mc) |
| Version | : | Client version 5.0.0.0 and greater |
| Revision | : | 1 |
SYMPTOMS
When sending an email to users for automatic notification, or manually by selecting email actions from the ILLiad client menus, when the email window opens a SQL error occurs producing the following message: SQL ERROR: Unmatched " near transaction #
The resulting email is missing the patron data, or parts of it, and the email cannot be sent.
ERROR MESSAGES
SQL ERROR: Unmatched " near transactionnumber
CAUSE
When patrons register for ILLiad for the first time, they must choose a delivery location from a drop down menu. If this drop-down is changed to include an invalid Delivery Location, or if it is removed entirely, then the user record is missing this required value.
RESOLUTION
To correct this problem, users should verify that their users have a "delivery location" from within the client:
1. From the ILLiad Client main menu, select Edit | Customer
2. Search for and double-click the patron you wish to verify
3. On the right hand side of the User Lookup and Edit form, check the delivery location field.
Sites should contact UNS (OCLC licensees) or Atlas (Original licensees) if this problem occurs, so that the issue can be corrected at its root, the web pages, and so the existing data can be updated correctly. Users without SQL experience should contact Atlas or UNS to assist them with this, if they are unable to do so themselves or the system admin is not available.
MORE INFORMATION
A list of valid delivery locations is available in knowledge base article 36448.
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